分类
标签
2-SAT AC自动机 BFS CDQ dfs DP fail树 FFT FFT&NTT FWT hash KD-Tree KMP LCA SPFA STL Tarjan Treap Trie 主席树 乱搞 二分 二分图匹配 二分答案 二维SPFA 交互 位运算 其他 最小生成树 分块 区间DP 半平面交 博弈论 可持久化 可持久化Trie树 后缀数组 图库 平衡树 并查集 插头DP 数学 数论 无旋Treap 日记 暴力 权值树状数组 栈 树DP 树套树 树状数组 树贪心 概率DP 模拟 欧拉定理 点分治 状压DP 生成函数 矩阵乘 线性规划 线段树 组合 网络流 群论 莫比乌斯反演 计算几何 贪心 费用流 高斯消元
212 字
1 分钟
POJ 2406 Power Strings 题解 KMP 适配函数
Description
Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef” . If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n) .
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
题解
主要考虑 KMP 中失陪函数的意义
因为整个串是会重复的
所以整个串的长度一定是串长减最后一个字符的fail的倍数
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=1000005;
char S[N];
int next[N],len;
void get_next(){
next[0]=-1;next[1]=0;
for(int i=2,j=0;i<=len;i++){
while(~j&&S[j+1]!=S[i])j=next[j];
next[i]=++j;
}
}
int main()
{
while(1){
memset(S,0,sizeof(S));
scanf("%s",S);
len=strlen(S)-1;
if(S[0]=='.')break;
get_next();
//for(int i=1;i<=len;i++)printf("%d ",next[i]);
//puts("");
if((len+1)%(len-next[len])==0)printf("%d\n",(len+1)/(len-next[len]));
else puts("1");
}
}
POJ 2406 Power Strings 题解 KMP 适配函数
https://www.nekomio.com/posts/2/