分类
标签
2-SAT AC自动机 BFS CDQ dfs DP fail树 FFT FFT&NTT FWT hash KD-Tree KMP LCA SPFA STL Tarjan Treap Trie 主席树 乱搞 二分 二分图匹配 二分答案 二维SPFA 交互 位运算 其他 最小生成树 分块 区间DP 半平面交 博弈论 可持久化 可持久化Trie树 后缀数组 图库 平衡树 并查集 插头DP 数学 数论 无旋Treap 日记 暴力 权值树状数组 栈 树DP 树套树 树状数组 树贪心 概率DP 模拟 欧拉定理 点分治 状压DP 生成函数 矩阵乘 线性规划 线段树 组合 网络流 群论 莫比乌斯反演 计算几何 贪心 费用流 高斯消元
255 字
1 分钟
[BZOJ 1954] The xor-longest Path Trie树 贪心
Description
给定一棵n个点的带权树,求树上最长的异或和路径
Input
The input contains several test cases. The first line of each test case contains an integer n(1<=n<=100000), The following n-1 lines each contains three integers u(0 <= u < n),v(0 <= v < n),w(0 <= w < 2^31), which means there is an edge between node u and v of length w.
Output
For each test case output the xor-length of the xor-longest path.
Sample Input
4
1 2 3
2 3 4
2 4 6
Sample Output
7
题解
本题是要求树上的路径异或 只要先预处理出每个点到根的路径的异或值又因为异或两次会抵消所以结果一定是对的
然后将所有点的异或值都插入一块Trie二进制由高到低
枚举每一个点 贪心的在Trie树中找就可以了
/*
* @Author: WildRage
* @Date: 2017-06-13 10:24:04
* @Last Modified by: WildRage
* @Last Modified time: 2017-06-13 10:24:04
*/
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct Trie_Node{
Trie_Node *ch[27];
Trie_Node(){
memset(ch,0,sizeof(ch));
}
}*root;
int ans;
inline void insert(char *s){
int len=strlen(s);
Trie_Node *now=root;
for(int i=0;i<len;i++){
if(now->ch[s[i]-'A']==NULL)
now->ch[s[i]-'A']=new Trie_Node,ans++;
now=now->ch[s[i]-'A'];
}
}
int main()
{
freopen("trie.in","r",stdin);
freopen("trie.out","w",stdout);
char s[105];
root=new Trie_Node;ans++;
while(scanf("%s",s)!=EOF) insert(s);
printf("%d",ans);
}
[BZOJ 1954] The xor-longest Path Trie树 贪心
https://www.nekomio.com/posts/3/